ClubRoadster.net banner

1 - 10 of 10 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
after this weekends' rain, water seeped in and the floor was all wet... this is the issue: when i press on the gas without the engine in gear the engine will jump off 3k rpms and wont go any further. also when i try to drive the car the engine will not rev past 3k... would this be an ecu issue?

i have a stock 1990 miata \

thanks in advace
 

·
Registered
Joined
·
1,165 Posts
It is very possible, I believe the ECU is in the passenger footwell "On a '90-'93, it's lying diagonally against the firewall, under the passenger's feet. Pull up the carpet and remove the four nuts and one bolt securing a coverplate over it."

so yes i'd say thats your problem, that or wiring of some sort.
 

·
Registered
Joined
·
1,155 Posts
Fuel filter? Fuel pump? Spark plugs? Wires?

I vaguely remember something about it....(in other words, I'm guessing.)

look it up on M.net
 

·
Registered
Joined
·
1,447 Posts
I had that happen once when a foam piece got sucked into the afm of my old BMW and stuck it open. Just saying'... It would start and rev smoothly but not go past 3k
 

·
Registered
Joined
·
568 Posts
He just claimed his floor was wet after the rain. Im pretty certain, its not his afm, or his injectors and most likely an ecu issue, derr
 

·
Registered
Joined
·
3 Posts
Discussion Starter #9
ok so i checked the ecu, and the contacts were all wet. cleaned them out with electrical cleaner as well as the circuit board and let them dry...

the engine will now rev past 3k but idles horribly low and runs rich... will have to try to set the idle speed tomorrow...

too much fuel being added?
 
1 - 10 of 10 Posts
Top