ClubRoadster.net banner

1 - 11 of 11 Posts

·
Registered
Joined
·
120 Posts
Discussion Starter #1
So Ive had this miata for about 8 months now without any problems. Engine runs great and motor is completely stock. So i started my car this morning and it stood 1200rpm on idle. So i was a bit curious about what was going on. I took it for a drive and everything was fine til i was heading to a stop sign.. i put my car on idle and she shuts off on me. i went from 3000rpm and it literally went to 0rpm without hesitation. It starts up and i would have to rev my car to keep it on. its totally fine when im moving. its just when i stop or put it on idle, the car completely shuts off. could it be fuel pump? ground? ignition switch?? i mean she starts up without any problem all the time but just shuts off right after. please help.

Anyone else had this problem? If so, any advice will be appreciated. thanks a lot CR.
 

·
Supporting Member
Joined
·
2,284 Posts
OK..you have a 91 Miata..

CHECK THE CODES!!!..all you need is a paper clip and the trouble code list from here...

http://www.miata.net/garage/Engine_Diagnostics.html

put a paper clip between GND and TEN in the diagnostics box under the hood on the drivers side fenderwell..turn the key to ON and count the CEL flashes....then consult the list for a clue as to your problem...makes it a lot easier than just throwing out ideas and parts...
 

·
Registered
Joined
·
120 Posts
Discussion Starter #6
Thanks a lot for your guys response. i will sure do that. and i will update as soon as possible.
 

·
Banned
Joined
·
5,894 Posts
Check you intake tract for cracks and leaks. The OEM units develop cracks on the bellows/flexible part. Some times if they get misaligned, it opens them up or it lowers enoght in the engine bay where the anternator cuts into it. Duct tape, electrical tape, RTV silicone can be used to reseal the cracks, cuts or holes.
 

·
Supporting Member
Joined
·
2,284 Posts
^ checking the codes is a good idea but it doesnt show if the timing is off just a heads up.
there would have to be a very good reason for the timing to be all of a sudden 'off'...8 months with no issues then this crops up...some component is going bad...and the CEL light does NOT have to come on for a trouble code to be present.

I had a coil go bad and the CEL did not come on...and the car quit..then ran..then quit...then ran...then quit for good...traced the problem to a bad ground that cooked the coil..not both, just one..and the car actually almost started on just 2 cylinders...the code check pointed me in the right direction from the getgo...
 

·
Registered
Joined
·
10 Posts
i have kina the same problem came to a stop and my clutch stayed in car stalled and turned on right away one mile later gear got stuck didnt come out. cant hear fuel pump anymore and car will only crank but wont start fuel pump is working though Idk what to do
 

·
Registered
Joined
·
120 Posts
Discussion Starter #10
UPDATE! so the problem happened to be the fuel filter. after changing it last night, the car runs perfectly again. :) i was so relieved that it wasn't something too major for my car. she reached 200k miles last week and shes running so strong! LOVE MIATAS! haha

PS. thanks for all of your guys input! i really appreciate it
 
1 - 11 of 11 Posts
Top