ClubRoadster.net banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
My wife's 93 Miata has been in the family since 99 and has run flawlessly with standard maintenance since purchase. Now 212K or 125 miles. Last Fall before putting the vehicle away for the Winter the car started running hot. Our mechanic has tried everything to try to rectify the problem from flushing to a new thermostat , new sensors, new waterpump etc. The heater and rad flush clear . The car runs hot at highway speeds ( past three quarters), two thirds at idle .The fan is coming on as expected. There is no coolant loss or mixing with the oil. The coolant at the lower part of the motor is green while the coolant at the upper part of the motor is muddy brown suggesting no coolant is flowing in the upper part of the engine. Has anyone had this problem and could anyone suggest a fix short of pulling the head. Is there anything that has been missed? There are additives that claim to remove mineral deposits but without flow I'm not sure how the additive would get to the clog. My mechanic has an 1800 motor out of a 99 but is not sure if it would mate up with the auto trans in our car. Any ideas? Thanks Richard
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Yes Flow is stagnant at the top end of the motor. My wife prefers the automatic trans so would her trans mate with the 1800 engine? Thanks for the response. Richard
 

·
R U ?
Joined
·
7,386 Posts
I would suggest putting the other motor on. her auto shouldn't have any issue attaching to the other motor. If the same problem happens... there's a whole lot of better diagnosing that needs to be done.
 

·
Sequence Number 1280
NA8 Pitcrew
Joined
·
3,060 Posts
Thermostat isn’t opening to allow water passage from top to bottom once warmed up. Completely remove thermostat to isolate that. If you remove it, open the radiator cap and leave it open, fill it with water with the car running. See if the water pump is actually moving the water? My bet is if you say all those are done already and have muddy looking water, your motor is shot with a bad head gasket.

Definitely should replace the motor. You might need a Flyin Miata conversion kit.
 
1 - 5 of 5 Posts
Top