ClubRoadster.net banner

1 - 20 of 22 Posts

·
Registered
Joined
·
889 Posts
Discussion Starter #1
So basically, as the title says I have a 94 that has a bit of a little fluctuation at idle which I never really minded as it never bothered me. Today I held the throttle steady and let it get to about 1800revs and then itll go down to about 1300 and come back up to 1800 and it keeps repeating the cycle, about 1 sec per flucuation. Only once I give it a little more gas will it start to rise. Any ideas or suggestions will be appreciated.
 

·
Registered
Joined
·
889 Posts
Discussion Starter #3
Just checked. None of them seem to be broken or cracked.
 

·
Registered
Joined
·
363 Posts
Well another thing to check is does it only happen when you have your foot on the brake as well? Or does it do it while in neutral?

If it happens while only using the brakes, you may have a leak/crack directly at the brake master cylinder.
 

·
Registered
Joined
·
1,319 Posts
i really dont think it's vacuum if the happens when the throttle is open. sounds like a fuel or spark issue.
 

·
Registered
Joined
·
889 Posts
Discussion Starter #6
It happens both when I have my foot on the brake and off so I dont think thatd be it. And yeah it does it in neutral. I havent tried with it in gear but the clutch in. Also sometimes if i shift at around 2200 the RPM needle will jump up like 750-1000 revs but the actual engine speed wont change. Not sure if that has anything to do with it....
 

·
Registered
Joined
·
889 Posts
Discussion Starter #8
Nope not leaking any coolant.
 

·
Registered
Joined
·
889 Posts
Discussion Starter #9
bump
 

·
Registered
Joined
·
889 Posts
Discussion Starter #12
So update on the situation. I was driving earlier and hit a pothole which cause my CEL to blink on for a second. Then on my way home it came on a couple times if i shifted too quick. So I checked the codes and got 03. So I'm guessing its the CAS or the wiring. Going to call a junkyard tomorrow and see if they have one. You guys know if its easy to swap out? Would be my first time doing it.
 

·
Registered
Joined
·
889 Posts
Discussion Starter #14
Did you also throw a 03 CEL
 

·
Registered
Joined
·
3,194 Posts
IF it is the CAS, it is easy to swap out, but you will want to have a timing gun on hand after you do, trust me!
 

·
Registered
Joined
·
889 Posts
Discussion Starter #16
Is it just the bolt to the side of it?
 

·
Registered
Joined
·
889 Posts
Discussion Starter #18
So now it wont start..... Still think its that cam angle sensor?
 

·
Registered
Joined
·
889 Posts
Discussion Starter #19
bump. Would really like to get this sorted.
 

·
Registered
Joined
·
889 Posts
Discussion Starter #20
Found the problem. broken ground wire, and a yellow and blueish wire going from the connector to the harness. Need to sauter them now...
 
1 - 20 of 22 Posts
Top