ClubRoadster.net banner
1 - 15 of 15 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Recently i jump started my miata with a portable 12volt jumper and accidently left it on while i drove away. 10 minutes later my car just turned off and now it wont start back up.

I have gas and power but NO spark...

checked all my sensors and they're all good and NO check engine light.

can it be the coil pack? (it is getting kinda hot when i have the key on) or maybe my Cam position sensor? ecu ecm? (bpe8)

anyone has any info on this?

thanks,
 

·
Registered
Joined
·
53 Posts
Most likely coil pack, or also could be ignitors. Does your tach move when cranking? Make friends with a miata person in your area and start swapping parts!
Highly doubt CPS and pretty sure not ecu either since its fueling, but theres a small possiblity that could be it. Also how could you know if you have or dont have a CEL if you car won't run lol?

Why was your car dead in the first place(have you been having alternator problems)? and are you sure the max voltage of the 12v jumper was 12v?
 

·
Registered
Joined
·
930 Posts
94s have internal ignitors in the coil packs. again see if the tach moves when you crank. if it does cas is ok and coils are out. if no tach movement the cas is bad. then there is that slight chance its both.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #4 ·
my battery was dead so i jumped started it and i accidently left it on while i drove away.

no i havent had any alternator problems. yes 12volt

94 miatas are rare!
 

·
Registered
Joined
·
1 Posts
I'm having a similar problem with my '94 Miata M. I changed the oil. Started the car. Checked the oil. Tried to start it again and it wouldn't. I've been told I might need a new ECU but I'm not sure if I do.
 
1 - 15 of 15 Posts
Top