ClubRoadster.net banner
1 - 11 of 11 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Ok, so... I bought this Automatic for my wife for $1,300 from a guy who just rebuilt the transmission from a shop. It didn't fix his not shifting up issue so he gave up. I thought, great, it's prolly the vacuum modulator, kickdown switch, or some other small issue. Well, it wasn't.

I replaced the two above mentioned parts, and drained and replaced the fluids. it still does the same thing.

does anyone have any troubleshooting tips for the auto trans? it would be greatly appreciated.

Also, side note, the ECU is B6AW, can anyone confirm this is the right ECU for a 1993 Cali emissions A/T? Although, I think has nothing to do with shift points, but the current one has a little rust and smells horrible (leaking capacitors?).

thanks in advance
 

·
Registered
Joined
·
453 Posts
wow, thanks a lot for the help guys. this forum is full or helpful people with well thought ideas. awesome. nice to know how you guys roll at clubroadster.
i completely agree with you. This place is joke for real info, unless your into the hellagarbage look. Try miata.net.
 

·
Supporting Member #5522
Joined
·
3,190 Posts
well i really cant help, however back when i first bought my miata it was a auto and it started slipping so i had it rebuilt. after it was rebuilt it would not shift into the final gear. the shop replaced trans housing, ecu, wiring harness... now its a five speed, we never found out what was wrong with it.
 

·
Official Armchair Racer
Joined
·
14,399 Posts
i completely agree with you. This place is joke for real info, unless your into the hellagarbage look. Try miata.net.
^This. I believe there is even a whole section devoted to automatics over there :fp: You might find people with experience that can help.
 

·
Supporting Member
Joined
·
280 Posts
try to adjust the cable
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #7 ·
i already have a posting on miata.net and have tried several things. thanks anyway guys.

and... yeah. i'll try "adjusting the cable". that's super helpful. i'll go through all the possible cables on the car and "adjust" them.
 

·
Registered
Joined
·
138 Posts
lol placeholder while i try to come up with something witty to troll this thread with :) jk.. But this likely won't help you at all, but back in the day i had a 99 c230 and it wouldn't upshift after 2nd gear and would bog down and do some really weird ****.. I changed out an 02 sensor and an maf and it fixed it, but mine was more of a hesitation issue rather than an actual transmission issue
 

·
Registered
Joined
·
300 Posts
Good. While you're at it, you should replace it with a manual transmission. If your wife can't drive manual, teach her. If she doesnt want to, you bought her the wrong car. Or you have the wrong wife.
Just saying, some people prefer an automatic transmission. Maybe he has to commute 100 miles a day... if you sit in traffic every day, and don't use the car for track/etc. an automatic is sometimes preferred :p He was just asking a question lol
 

·
Registered
Joined
·
196 Posts
you might have to end up rebuilding the auto. a buddy of mine had that same problem but in a not miata - the sprag wore out and well..didnt shift
 
1 - 11 of 11 Posts
Top