ClubRoadster.net banner

1 - 7 of 7 Posts

·
Supporting Member
Joined
·
60 Posts
Discussion Starter #1
Can anyone clue me in on how to attach the battery clamp?
I had to replace a battery and I can't seem to see where the
hook on the antenna side goes...sooo, if I tighten it on the
tail light end vertically, the top holder pops off. Really appreciate
any help. It's the standard Westco with factory clamp, '95.

Oh, it sat for three months as I had a broken leg and nooo assistance
to start it.

cheers.
 

·
Registered
Joined
·
1,785 Posts
take the battery back out, familiarize yourself with how it all works sans battery and then you should be able to put it back together without being able to see back there.
 

·
Supporting Member
Joined
·
60 Posts
Discussion Starter #4
take the battery back out, familiarize yourself with how it all works sans battery and then you should be able to put it back together without being able to see back there.
I can see back there fine. I just see no hole or other place to slip the hook into. Appreciate the help, but man, nobody else can answer this?
 

·
Supporting Member
Joined
·
60 Posts
Discussion Starter #6
Thanks! I haven't had to change the battery for 17 years, and installed the Westco. The hole doesn't seem to match up, but I'll check over the weekend.
 

·
Supporting Member
Joined
·
60 Posts
Discussion Starter #7
Thanks! I haven't had to change the battery for 17 years, and installed the Westco. The hole doesn't seem to match up, but I'll check over the weekend.
I wasn't so hard, did as you said. i'm still getting a engine check light:
upper left in the standard configuration. I think I have to get it fully charged by driving a ways till it goes out.

Don't think it's an alternator. No problems on the belts. Does Westco
ship them low charged? But again, thanks.
 
1 - 7 of 7 Posts
Top