ClubRoadster.net banner

1 - 9 of 9 Posts

·
CR.net Old Geezer
Joined
·
1,212 Posts
Discussion Starter #1
I've been having a problem with my Greddy kit loosing boost at higher RPM's, yet im not sure if i have a boost leak or the Starion intercooler is just not sufficient enough.

I'm currently running 15psi(hi) and 6psi(low) on a dual stage Turbo XS manual boost controller. Boost holds well at 6psi up until redline, but when under load on 15, it hits 15lbs for a second or two then drops down to about 9-10 psi.

I've checked all of my hoses(which are clamped with t-bolt clamps) to the intercooler as well as the clamps on my pressure lines to the turbo,wastegate, and boost controller.

I havent ever had a problem with a BOV leaking and i dont believe my HKS is, but im sure its a possibility. Anyone have any ideas?
 

·
CR.net Supporter
Joined
·
242 Posts
I'm sure you've thought of this, but are you sure that you're not just spiking to 15 lbs? Its a common problem. Have you maintained a steady 15 lbs of boost prior to now?
 

·
CR.net Supporter
Joined
·
242 Posts
For myself, I am maintaining 14 lbs constant pressure @ WOT with a very obvious and whistling leak. My first guess would be the MBC.

You would more than likely hear the leak at your boost levels.
 

·
Registered
Joined
·
1,110 Posts
my rx7 had similar problem at one point, it was a tiny crack in the turbo outlet coupler. it was so small that I couldnt see it untill I took the hose clamp off and saw the split. about 1/4" long and totally sealed looking when the clamp was on...
 

·
Senior Member
Joined
·
4,296 Posts
1 - 9 of 9 Posts
Top