ClubRoadster.net banner

1 - 5 of 5 Posts

·
Whiskey makes me Frisky
Joined
·
4,545 Posts
Discussion Starter #1
So I just got my check engine light looked at, cant remember the code as it was done a few hours ago and only just sat down but it has something to do with the catalyst temperature or efficeny below threshold. Any one have any experience with this or know what I can do to fix the problem, the guys at autozone just said it may be a faulty cat, o2 sensor or oil leaking into the rings...hope its not the later.


Any help, ideas or expertise would be much apreciated
 

·
CR.net Supporter
Joined
·
332 Posts
My 99 Odyssey was faulting a code similar. I changed the front O2 sensor and It still had the code. Next step is to check the temp difference between the front of the cat and the rear part. There should be about 100 degrees difference(exit should be hotter). You can check it with a laser thermometer.
More than likely it's the Cat.
 

·
Whiskey makes me Frisky
Joined
·
4,545 Posts
Discussion Starter #5
excellent, that will give me some time to sort out my problem with the radiator fan.

I thought on the 99's that the cat was part of the midpipe, so is this something that can be replaced?

what about checking o2 sensors is there a way I can do that and see if they are in proper working order?

I did plan on putting on new headers, mid and rear section on at a later date and since I dont have to worry about emissions living in florida and all is this CEL going to effect my drivability untill I get that done?
 
1 - 5 of 5 Posts
Top