ClubRoadster.net banner
1 - 20 of 20 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter · #1 ·
Hey y'all! Im having some trouble with my 93 miata build.

The clutch went out suddenly last week.. I replaced the slave cylinder and bled it out and It started working again.. within an hour of driving it was gone again. No clutch response at all. I bled the cylinder again and It worked for another 45 minutes and now its out...

Is there a leak? where could it be if all the lines are hardlines? Not sure what to do...


Any help? :|
 

·
Registered
Joined
·
10,262 Posts
Hey y'all! Im having some trouble with my 93 miata build.

The clutch went out suddenly last week.. I replaced the slave cylinder and bled it out and It started working again.. within an hour of driving it was gone again. No clutch response at all. I bled the cylinder again and It worked for another 45 minutes and now its out...

Is there a leak? where could it be if all the lines are hardlines? Not sure what to do...


Any help? :|
Sounds like your master cylinder may be bad also.
 

·
Premium Member
Joined
·
366 Posts
Not even worth your time to rebuild. Go to autozone. I just replace the master the slave and the rubber line for just under $100 bucks. Took about an hour to install and bleed. Easy. Then you can forget about it.

Ps the master will just come off from the engine bay. No need to get under the dash like most other cars. Just unbolt.
 
1 - 20 of 20 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top