ClubRoadster.net banner

701 - 713 of 713 Posts

·
Constantly Spooling
Joined
·
1,140 Posts
Discussion Starter #702
One year later;) Glad to hear you will be getting back to Brutus, Dedin! :)
He's been sitting for some time sadly, so I assume I'll have some fuel related issue
Fuel pump, injectors need cleaning, tank?

Never got him up up but he did move under
TBT, but yeah, I'll be back in a few weeks :haiguyths:

Have to keep an eye out.
:bouncin:
 

·
Constantly Spooling
Joined
·
1,140 Posts
Discussion Starter #703
Haven’t updated since I moved back home.

Car starts and runs. Swapped injectors back to RX7 460’s and it’s idles again.

Thought I had injector dead time correct but clearly not, ill get to a tuner and let them sort that.

Went for a decently long hour drive on 303, and it’s fucking being open header.

Need to get straight pipe made and connected. Get to tuner and continue driving. Took it to a shop... tried to charge me $500+ for a straight pipe... cause he wanted to the flanges to match....listen here bud, ain’t gone happen.

Leaked some coolant so I need to find the source and can go from there. Hoping it wasn’t the welded spot but gotta pay to play




That’s all I got.
 

·
Constantly Spooling
Joined
·
1,140 Posts
Discussion Starter #708
**** it’s been a while huh, well not much to update other than starter getting stuck issue was fixed.

Got the car put back together again, hood pins are on, along with headlights and all.

Got a turbosmart BOV just for more reliability than the eBay one I had bought years ago.

Just saving at the moment for a proper tune and that’s about it

Some pics









At this point since I’m on standby and the car drives well, I have a cut rear bumper and want to cut the tuckin99 so it doesn’t hang off a lot, but debating on the line of cutting I guess. Other than that, this is current again.





Going to swap oil to normal again instead of break in, crossed the 500mile mark a little while back and it’s time for some actual boost.

Probably swap springs cause I couldn’t tell you what I put in there years ago now, and do flush of radiator and all (no overheating) but just as precaution from sitting for some time.

Okay now we’re updated.
 

·
Constantly Spooling
Joined
·
1,140 Posts
Discussion Starter #711
At this point I’ve swapped springs but only issue I’m having before proper tune is overboosting.

10lb spring in but easily going over and hitting boost cut when I attempt to floor it.

Gonna start looking for some vacuum leaks, but moved the wastegate vacuum source from the turbo housing itself and just using spring pressure.

So I’ll do my research as to why but if anyone’s got thoughts, throw them out there!



Old spring




I also recently tired to hook up a VTPS bmw sensor, did what I believe to be correct soldering on Megasquirt, but still doesn’t appear to be working, moved the cables on the sensor but no go.

Not sure what I’m missing there

But besides the overboosting, Brutus is back and reliable!
 

·
Registered
Joined
·
5,011 Posts
Great to see Brutus up and running, Dedin! Hope you and the family are doing well, don't be a stranger!
 

·
Constantly Spooling
Joined
·
1,140 Posts
Discussion Starter #713
Great to see Brutus up and running, Dedin! Hope you and the family are doing well, don't be a stranger!
Thanks man, doing damn good honestly, no complaints here really.

driving is fun, just doing maintenance now that I have some time

Im around now that I have a car again!
 
701 - 713 of 713 Posts
Top