ClubRoadster.net banner

1 - 11 of 11 Posts

·
Registered
Joined
·
559 Posts
Discussion Starter #1
well i did a self diagnose on my car. it read a 15...which is oxygen sensor (output too low). im glad i know what it is...but how exactly do i check and fix that.

thanks,
tim


*ok i got the O2 sensor fixed...the check engine isnt on anymore. but the car still idles rough. when it idles and when i drive it...it'll bog on me (rpms lower and rise in a fluctuating pattern) and the check engine light is on. but when i go to do a diagnostic test nothing comes up. so it isnt anything the ecu is reading. what do u guys think it is?

i really want to drive my car...so please help me out.
 

·
Registered
Joined
·
189 Posts
Re: Diagnosed my problem, but how exactly do i fix it?

Sounds like you all ready checked it

As far as replacing it you need to go to your FLAPS and pick up a bosch 1 wire O2 sensor. It should be about $35

Steps to replace...

1. Find the sensor, it is in the exhaust pipe near the fire wall
2. cut the old wire
3. take the old sensor out using a deep socket or a wrench
4. install the new sensor, have to use a wrench unless you buy a special socket with a slot in it for the wire
5. crimp the new wire onto the old one

you might want to check and make sure that you were not running rich (that may have been what killed it)
 

·
Registered
Joined
·
229 Posts
bump

...read the edit in the first post.
*ok i got the O2 sensor fixed...the check engine isnt on anymore. but the car still idles rough. when it idles and when i drive it...it'll bog on me (rpms lower and rise in a fluctuating pattern) and the check engine light is on. but when i go to do a diagnostic test nothing comes up. so it isnt anything the ecu is reading. what do u guys think it is?
so... is the check engine light on or off...?

my advice? drive it 'til the wheels fall off!
 

·
Registered
Joined
·
559 Posts
Discussion Starter #6
the check engine light is off...but comes on only when the rpm fluctuation occurs.

i would drive the **** out of it if it was running well enough to where i could do that.
 

·
Registered
Joined
·
559 Posts
Discussion Starter #9
the ignition switch in the steering colum? the ignition would cause it to do while im driving?

i forgot to mention that it gradually got worse over the 3 days it has been running. it started to do it while i was driving and now it does it all the time.

i got new wires but im gunna go ahead and get new plugs soon.
 

·
Registered
Joined
·
559 Posts
Discussion Starter #10
k...got the rpm drop thingy fixed. i got new plugs and tightened up a loose ground.

now thats over i now hear a slight tapping noise on the upper/mid region of the motor. i figure its fuel ping but i put some 89 in it earlier and it hasnt made a difference, so i guess its lifter?

also when i stop at a light the rpms sit at 2k and after awhile it goes to 1k. how do i fix that problem?
 

·
Registered
Joined
·
189 Posts
k...got the rpm drop thingy fixed. i got new plugs and tightened up a loose ground.

now thats over i now hear a slight tapping noise on the upper/mid region of the motor. i figure its fuel ping but i put some 89 in it earlier and it hasn't made a difference, so i guess its lifter?
If it were pinging it would get worse under load... Try an oil change, maybe a 5W20

also when i stop at a light the rpms sit at 2k and after awhile it goes to 1k. how do i fix that problem?
check your vacuum lines, and maybe a good cleaning of the throttle body
 
1 - 11 of 11 Posts
Top