ClubRoadster.net banner

1 - 3 of 3 Posts

·
Esteemed Member
Joined
·
4,380 Posts
Discussion Starter #1
I got this message from a myspace roadster head, I know some of you guys can help out with the problem. I know nothing of turbo systems. Here's what she wrote to me, I referred her to CR.net also. :)

myspace person said:
ok so this is going to be a long thread, but its the only way i can explain whats going on in its entirety. and although its long, i would really appreciate it if you would just read it and see if you might know something about it. please... ok here goes...

in july i turbo charged my miata. it has 160k miles. brand new greddy turbo kit. everything has been fine until this month, which is 4 months later. the only problem i have had so far prior to this incident is that the turbo keeps melting my afm after a while, even with the heat gaurd. so when it melted my afm the first time, the car would run, but when you would try to accelerate it would sit there and putter. so i replaced it and it was fine. i ran it with the 2nd afm for about 3 months until now, then my car started acting up again. now when you start it when its cold blooded it will stay on for about a minute, then idle out really hard and die out. it used to always do this, but after dieing the first time, you could start it righy back up and it would stay on and no problems. but then all of a sudden out of no where one night i got off of work, i started it, and it died like normal, but then when i restarted it, it kept dieing out again, constanly,no matter if it was warm or cold,it didnt matter. so that night i needed to get home anyways, so i just kept revving the rpms really high to prevent the rpms from dropping and dieing out. when i drove it, it would drive perfectly fine sometimes, then it would act up. what happens when it acts up is, no matter no much you give it gas, the car won't go, like its not recognizeing how much air or fuel is comming in. then after flooring the gas for about 5-10 seconds it would all of the sudden kick back in and the car would have power again. then the next next few min it would be completely fine, then it would happen again.

so since it kind of had a similar response to when my maf melted the first time, i went and picked up another afm and put it it. i started it up cold and it didnt even die once. i thought the problem was fixed. then i went to drive it around. then after 30 min of driving it did it again. the poblem was back. no matter how much i floored it, it wasn't recongnizing that i was until about 10 seconds of holding the throttle all the way down, sometimes even longer. if i held the throttle all the way down at a steady hold (not "revving" the rpms) it would rev just like i WAS revving/fluttering the throttle. for example, i held the gas at a steady throttle, but for some reason the rpms would rev up but then drop down to 1000 rpm as soon as it revved up to 2000, like i was revving it like some racer trying to get another racers attention or tryin to show off o something...so then i thought maybe i just got a bad maf? i went and got ANOTHER one and immediatly the problem persists. so then i though, maybe its not the maf. but if it wasnt, why is it that when i changed the maf the previous time, it ran perfect for the half hour?

so now i stand, the car starts and seems to run perfectly fine, except when its cold she likes to keep dieing out repeatedly and constanly at idle. it just idles out real hard and dies. but if i rev it up it stays on, but when i rev it up it putters and hesitates and no matter how much i floor it, it will drop back down to 1000rpm as soon as it hits the 2000 rpm mark, even if im flooring it. i am able to drive it, and it acts fine,but then the next min it will sit there and bog, then it will be fine again. i dont get it....i got some othe ideas on what it could be, but id like to have your own opinion instead of stating what else i thought it could be and you basing it off of what i think. id like your own opinion. my problem could also be anything, so anything will help.

i understand that reading all this is kind of a lot to take in, especially in texts, so if you have any questions or need me to explain more verbally in better detail with cool sound effects (ha ha) PLEASE call be free to call me. its my daily driver and i need it running....

360-486-4710
 

·
Senior Member
Joined
·
4,296 Posts
have her check Vacuum lines. they can have the same effect.
its hard to say cause each greddy car can be a total custom install.
but she needs to be sure her ignition timing is right, plugs gapped ,etc.
first off though, check Charge Pipes, Vacuum hoses.
 

·
Supporting Member
Joined
·
31 Posts
Also check wiring to the AFM to make sure it's not melted anywhere. The AFM is the ground for the fuel pump so if the wiring is fried or shorting to ground it may/may not run correctly. Also check spark wires, when they get old, they short out and cause all kinds of funky idle/driveability problems (bouncing tach is one of the first signs,like it will drop to zero and then back to the normal rpm while driving). Good luck.
 
1 - 3 of 3 Posts
Top