ClubRoadster.net banner
1 - 7 of 7 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
does anyone know any common miata ignition problems. my car is currently giving me a code 1 & 3 with both deal with ignition

code 1 is Ignition Pulse.....ignition coil, igniter and or pcm circuitry
code 3 is Ignition G Signal-distributor and PCM circuitry or components

i'll be driving and the car just starts going crazy like the RPMs will just start jumping around resulting the car to start jerking and it sounds l ike the engine starts to cut out every time it starts to act funny. i'll post a video as soon as i can or i'll post a link to it

any help is helpful. and where is the igniter located?
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #2 ·


hopefully everyone can see this video. sorry for the shitty audio it was taken with my phone but watch the RPMs. the car starts to sputter really bad like it wants to give out and the codes are telling me its an ignition system problem
 

·
Supporting Member
Joined
·
2,284 Posts
Would really help if we knew what year Miata you have...miles..recent work..mods..etc..

Ignition issues can be caused by a bad ground...ask me how i know this one...

check and clean ALL grounds in the engine bay...at least 3 if a 1.6..4 if a 1.8..and one all the way at the rear of the PPF

Bad ground can cook a coil pack..as me how I know this one.

Joe
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #4 ·
It's a 1.6 miata with 186k on body. On vehicle just headers and intake and advanced timing. Well car took a crap on me on the freeway but I thought it was the clutch so I replaced the clutch and the same problem occurred so I was told it was my master clutch cylinder so my whole clutch system is new. Transmission clutch and pressure plate slave cylinder master clutch cylinder and all likes hard and soft lines and still. So I started to really listen to the car and it sounded like the car was not getting gas like it was turning on and off.
I just replaces the fuel filter because I thought it was fuel and out of no where I remembered to run the codes and it gave me the codes 1 & 3
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #6 ·
no i havent checked the cam sensor. i don't know why but i am. ima try to check it. so far my to do list for today is check grounds 3 in engine and 1 on ppf. check cam sensor. man i hate electrical
 
1 - 7 of 7 Posts
Top