ClubRoadster.net banner
1 - 20 of 28 Posts

·
Mostly Harmless
Joined
·
1,540 Posts
Sure is! :D
No modification needed at all. Just be patient with 'em...the rubber that holds them in place (wraps around the metal on brake & clutch) isn't very malleable.
 

·
ClubRoadster.net Founder
Joined
·
4,631 Posts
I thought the dead pedal from an NB is needed on an NA for the MS set to work.

Can someone confirm this?
 

·
Mostly Harmless
Joined
·
1,540 Posts
Well, a matched dead pedal comes with the set. I wouldn't say it's really needed unless the end user just wants that matched set look. Mine's still in the box as I didn't feel like whipping out the suggested self-tapping screws at the time. One of our local guys snagged a stock dead pedal from, I believe, a '01 model to use with the MS pedal covers.
 

·
ClubRoadster.net Founder
Joined
·
4,631 Posts

·
Registered
Joined
·
713 Posts

·
Registered
Joined
·
262 Posts
does anyone have a picture of these pedals in an NA? My pedals are all screwed up, so this has me thinking. :)
 

·
Registered
Joined
·
125 Posts
you're in luck...
just installed these last night, haven't decide if i want to used the dead pedal yet.
word of advice...spray some lube on the clutch and brake pedals when installing, they were a bi*ch to put on.



benjamin
 

·
Registered
Joined
·
125 Posts
Anybody have pics of the back of the pedal covers not installed?
it looks like the back of the original rubber pedals. but i don't have any pictures, and i don't want to take them out to take pictures, too much work.

i have the picture instructions at home, i will try to scan them for you.
EDIT: here are the instructions as promised...






benjamin
 
1 - 20 of 28 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top