ClubRoadster.net banner

1 - 11 of 11 Posts

·
Registered
Joined
·
551 Posts
Discussion Starter #1
I recently purchased a set of trmotosports 15x9+ 36 which rub on both upper and lower control arms on the driver side and on my sway bar on my passenger side at full lock. I am also running a set of i concept tie rods which due indeed give me more angle and is a factor in the rubbing, but prior to running these wheels i had a set of 15x8 +20 and everything was fine. As a result to the new rubbing i went ahead and purchased a 5mm spacer from h&r to see if it would cure the rubbing at full lock. It helped a good amount but i am still rubbing, now have come to a conclusion that A my rack may not be centered, B I need bigger spacers or C my car may have been hit.

If anyone as an idea or a word of advice i would greatly appreciate it, the car is aligned and drives straight I am a bit out of words and would like to go in the right step to fix the problem
 

·
Registered
Joined
·
424 Posts
Not sure on what you could do, but to get a bigger spacer maybe? Have you check to see if the car has been in hit in the past? For my front 6ul's (15x9 +36), I got 20 mm spacers and I don't rub at all, even at full lock. Before the spacer though, the inside of the wheels was hitting everything, I swear hahaha.
 

·
Registered
Joined
·
424 Posts
Well now that I slammed the car recently tucking almost all of the sidewall, I do rub. But before when I was about a finger or so, I didn't rub at all. Depends on your tire size though too. My fronts are 15x9 +16 effective w/ the spacer, on a 195/50.
 

·
Gang-Ban Organizer
Joined
·
2,720 Posts
a few questions...why do you need more turning angle if you're running 225s on a 9? If you're drifting you should have flares and spacers anyway...I'm not seeing the logic here.
 

·
Registered
Joined
·
551 Posts
Discussion Starter #11
Because prior to me having the 225's i was sliding

I was fine sliding with my setup I didnt need flares or spacers
 
1 - 11 of 11 Posts
Top