ClubRoadster.net banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello! I have a miata 1.6 from 93. It's about 9000 miles now.

I have this problem that i don't really know how to solve so I was hoping you guys could help me out.

The thing that happens is when i try to start the car is that the car starts easiely but completely dies after a second or two. if I try to start the engine again without restarting the ECU, the car does not start. If i restart the ECU (turning back the key the whole way and turn on again) the car starts and then dies. I have had it in three repairshops now and nobody is sure what it is. I think the fuel system works and if i remember right, the guys at the shop tried the fuel pump and it was OK. the only thing that i had problems with earlier was the car just died at a traffic light and i had to restart it to get it running again. that was maybe 1 or 2 weeks before this main problem. otherwise no problem. I was thinking maybe its could be the MAF that causes this? but that would be easy to check at a shop right? I also thought that it maybe could be the crankshaft position sensor och the camshaft sensor.

Do you have any other tips och ideas? I'm not really very good at this so any help would be awesome! Sorry if my english bothers you. I'm from sweden :)
 

·
Registered
Joined
·
2,140 Posts
I had an issue with mine and it turned out to be my fuel strainer on my fuel pump (and bad gas). It had two holes in it.

I cleaned out my pump with a battery to turn it on and some pure fuel injector cleaner. You suck some in, then reverse the battery to push it out. You can do it with the other side too.

After that, two gallons of fresh gas, and a new strainer, it started right up.

Otherwise, if you search "Miata no start guide" there's a thread from miata.net that has a good troubleshooting guide on it.

Sent from my SM-N910V using Tapatalk
 
1 - 3 of 3 Posts
Top