ClubRoadster.net banner

1 - 5 of 5 Posts

·
SHUEtuning.net <3
Joined
·
300 Posts
Discussion Starter #1
ok so i have a couple of questions reguarding my stock ugly cd player/radio in my 99'...

1) why am i missing a (20) fuse in the "audio" area in the fusebox?

2) my cd player only wants to play sometimes meaning 99.8% of the time it doesnt work just spits out cd's...

3) i have to bang the crap out of it to work sometimes (like the power or to get the radio or for it to light up or show the time........ ;o(

has anyoen else had problems with their stock radio?

i know im planning on getting a new deck in there (JVC KV-ADX2 :D ) but for now i have to deal with what i got.

please help me out. i hate my radio. i go on A LOT of trips and im not an ipod person or satellite radio person... i need my bumpbump when im on the road.

thanks.
 

·
Speed Racer
Joined
·
4,690 Posts
*sigh* I got my 1991 BRG that has a stock CD player in dash and it will take the cd in, and then spit it back out. Also, sometimes the radio won't turn on, I push the button and nothing happens. Then a minute later the button works and it turns on. Oh well. Guess I'm subscribing to hear what others say.

I think I'm gonna yank the radio out, I already took out the door speakers (JBLs from PO?) and saved 3.5 lbs. haha
 

·
Registered
Joined
·
605 Posts
My 2000 OE radio works about 98% of the time, but some days it'll act up strangely... especially the CD player part; it doesn't spit out discs, but the display will go blank or freeze and/or it'll stop playing. It works just well enough that I can't bring myself to buy an ugly aftermarket head unit.

The audio fuse you don't have is probably for the factory optional BOSE amps.
 

·
Esteemed Member
Joined
·
2,930 Posts
hmm.. my pos aftermarket cd player does the same crap, sometimes spits out cd's, skips real bad on the slightest bumps from the road, intermittently turns itself off.
 
1 - 5 of 5 Posts
Top