ClubRoadster.net banner

1 - 9 of 9 Posts

·
Registered
Joined
·
1,533 Posts
Discussion Starter #1
I recently did a bunch of work to my car at once (suspension, roll bar, body mods, wheels, steering wheel) and now my car is randomly not starting. It wont even crank or turn over. I thought it was due to the battery at first, I couldnt even jump it, but when I replaced that the only thing that works is the headlights. The windows wont roll up and down either, which is weird.

I checked all of the fuses and they seem to be good. I know starters like to randomly go out, but it has not given me any issues before. The car sat for about a week and im stumped st what it could be. Im leaning towards something with the ignition switch, since I messed with the steering wheel but have never had an issue with installing one on a car before. Any clues?
 

·
I have poop issues.
Joined
·
1,588 Posts
I would say this has to do with the ignition switch....check all wiring underneath to ensure you didn't unintentionally screw something up. If your headlights turn on but windows/radio don't work, then the car isn't even going in to accessory mode.
 

·
Registered
Joined
·
1,533 Posts
Discussion Starter #4
So I just pulled it all and it looks like the two wires going to the ignition switch are good. I carefully put everything back together but still hesr no fuel pump and am getting no power to rhe accessories.
 

·
Registered
Joined
·
1,533 Posts
Discussion Starter #8
As stated in the post above you, it WAS the main fuse. It looked to be intact, but was broken. I took a drive down to the local autoparts store, bought a new fuse, popped it in and it fired right up!

Thanks again for everyone that provided with me with some insight!
 

·
Supporting Member
Joined
·
2,284 Posts
I saw the word 'hopefully' in the post above mine...and there was no definitive answer...

There is another thread going with a similar problem...and I suggested the main fuse there...
 
1 - 9 of 9 Posts
Top