ClubRoadster.net banner
1 - 11 of 11 Posts

·
Registered
Joined
·
490 Posts
Discussion Starter · #1 ·
Recently as ive been driving the smell of gas arises when i accelerate. The smell kind of goes away when I come to a stop but its still there.

Ideas for things to check? Ive checked the seals in the trunk to the gas tank and i dont see anything wrong with any of them. Im I running super rich? My exhaust has also been extra poppy (not sure if that has anything to do with it)

I need some idea of what to start looking at/for. Thanks for any help.
 

·
Supporting Member
Joined
·
3,469 Posts
Check your evap lines where the fuel pump is located under the parcel shelf in the rear. I had a black hard evap line that had a hole in it from rubbing on a metal pinch weld and opened up letting in gases in the cabin.
 

·
Registered
Joined
·
490 Posts
Discussion Starter · #4 ·
Ive checked those and didnt see anything super obvious, but the car was off and gas evaporates pretty fast so Ill recheck those. Im going over to a buddies house later so ill be able to check those while the car is running/revving
 

·
Supporting Member
Joined
·
3,469 Posts
What sideshow says as well.

You can pull the evap hoses a little and get a flash light to look in there. Twist and turn i a bit. The hard line hoses are connected to a valve. If there is a hole, it'll look very small.

Are you throwing a code?
 

·
Brunettes > Blondes
Joined
·
2,336 Posts
maybe your spark plugs are too tight? sometimes that makes the car run "rich"
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top