ClubRoadster.net banner

1 - 13 of 13 Posts

·
Registered
Joined
·
563 Posts
^^^Mine did the same thing. I would also love an explaniation!!!
 

·
Registered
Joined
·
404 Posts
Mine also does it when the engine is cold. I figured its just over fueling cuz sometimes I get a little puff of black smoke.
 

·
Registered
Joined
·
67 Posts
I have this prob too. Only it occurs when its warmed up sometimes too. It also makes a weird sucking noise (not the filter). Anyone have a clue what that noise is? its a deep nasty skkkkk* noise. It doesnt sound like metal but like someone is houking a loogy :x
 

·
Registered
Joined
·
1,239 Posts
I have this prob too. Only it occurs when its warmed up sometimes too. It also makes a weird sucking noise (not the filter). Anyone have a clue what that noise is? its a deep nasty skkkkk* noise. It doesnt sound like metal but like someone is houking a loogy :x
that I am sure is a vacuum leak. See if you can find the source of that noise. It's probably a vacuum line that's loose.
BTW mine does this too. I'm about due for new plugs, wires, fuel/air filters. I'll see what happens with that. Otherwise maybe O2 sensor, Thermosensor, etc. The list goes on.
 

·
Registered
Joined
·
1,239 Posts
I have this prob too. Only it occurs when its warmed up sometimes too. It also makes a weird sucking noise (not the filter). Anyone have a clue what that noise is? its a deep nasty skkkkk* noise. It doesnt sound like metal but like someone is houking a loogy :x
that I am sure is a vacuum leak. See if you can find the source of that noise. It's probably a vacuum line that's loose.
BTW mine does this too (stumbling at low rpm, not a vacuum leak). I'm about due for new plugs, wires, fuel/air filters. I'll see what happens with that. Otherwise maybe O2 sensor, Thermosensor, etc. The list goes on.
 
1 - 13 of 13 Posts
Top