ClubRoadster.net banner

1 - 16 of 16 Posts

·
Brah.
Joined
·
7,484 Posts
Discussion Starter #1
picked up the most bad ass truck ever!!!











and here is some new pics of the v8 swap!




























i am too tired or i would write some stuff about whats going on but most of it is waiting on parts.
 

·
Brah.
Joined
·
7,484 Posts
Discussion Starter #10
Its Rex's car in the movie, Napoleon Dynamite!

How much did you get for it? I wanted one so badly, but most are up north or have become rust buckets.
thanks man! price was not too bad 125k miles mint. 3000

brats are so sweet.

what did the v8 come out of?
the V8 came out of a 99 explorer......this was a BAD idea. we should have went with a HO 5.0 out of a foxbody.
 

·
Brah.
Joined
·
7,484 Posts
Discussion Starter #11
we ended up using martin's kit for the car which has been nothing but waiting....4 months and we still dont have all the parts and even had to send some stuff back. plus we have had to customize a custom kit for this to bolt in.


right now what we lack is....

drive shaft
left axel
wiring ( about 10 wires that need to be spliced in)
try to figure out how to bend the custom headers to get a spark plug in.
put the radiator in
figure out why the starter is not getting power
work on getting rid of the auto tranny stuff
and i am sure i forgot some stuff.
 

·
Finger lickin' good...
Joined
·
6,605 Posts
the V8 came out of a 99 explorer......this was a BAD idea. we should have went with a HO 5.0 out of a foxbody.
Actually, the Explo motor has the better heads and intake, GT40P or X, it's cast into the heads under the valve cover. You could dump some money into a Fox Body motor and not pull the same results as the 96-98 Exploder 5.0 starts from. Check the casting numbers, is the intake a 2-piece upper?
 

·
Brah.
Joined
·
7,484 Posts
Discussion Starter #13
yeah it does have GT40P heads and the cobra intake but the motor is verry diffrent compaired to the HO. the arms that hold the ac/ps/alt are too big to use also caused a problem getting a belt on the motor since we had to do custom mounting plus ditch the ps and ac. the wiring for the motor runs into the auto tranny then back out making it a bitch to wire, oilpan is the wrong shape so we had to buy a new one, trying to get a flywheel to bolt up was a bitch we had to order 2 diffent ones, ect..... in the end we had to ditch the explorer wiring harness and went with a HO wiring harness and a distributor.
 

·
Brah.
Joined
·
7,484 Posts
Discussion Starter #14
and the biggest issue is we are college students working full time jobs trying to do this and this is a fucking $$ pit. but we are doing a better job then anyone else we have seen on miata.net.
 

·
Finger lickin' good...
Joined
·
6,605 Posts
I know the frustration. My dad has been fitting a 302 into his 91 explorer for the past year. Only the weekends to work on it for the time frame. Many different mounting brackets, rewires, ignition boxes, 1 fire and 3 wire harness' later, it runs and drives. Just finishing up on it a little lately. I don't know why Ford decided to run their accessories furthur out in the later years.
 
1 - 16 of 16 Posts
Top