ClubRoadster.net banner
1 - 7 of 7 Posts

· Banned
Joined
·
20 Posts
Discussion Starter · #1 ·
Ok so today when i started driving my car i noticed once again that the clutch pedal was feeling a little strange, when ever i went to accelerate the clutch would start engaging when im like half an inch off the floor with the pedal and the pedal also felt really soft. I noticed this twice already but doesnt happen often whatsoever. Only reason i noticed it is because i usually feel that the clutch starts to engage and the car starts to move when i have the pedal almost half way released. My miata only has 53k miles and its a 97. Is it normal for these miatas to do that every once in a while? Or might something be going bad? Cuz theres no noises or anything wlse just that strange feeling in the pedal. Thanks in advance.
 

· Registered
Joined
·
911 Posts
Leak and/or air in the clutch line? see if theres fluid by your lower passenger side control arm where the slave cylinder is after the car has been parked overnight or something. See if theres a leak somewhere in the section of line that goes from the master to the slave.
 

· Registered
Joined
·
48 Posts
After checking fluid levels, start at the slave and work back.

If you dont see any fluids on the ground, look at the FL control arm with a flashlight (mine dripped there), check the rubber cover on the slave, connections to the hard line..

Bleed it, if still nothing I would look at the master.
 

· Registered
Joined
·
113 Posts
Sounds similar to a problem I had with the slave cylinder. Pedal got softer and eventually needed to pump the clutch just to shift. Not a pretty sight once you're grinding gears. Check the above and try to replace it asap.
 

· Supporting Member
Joined
·
2,265 Posts
Probable hydraulic problem...check the clutch master for low fluid level..the little one next to the brake master. And don;t just look at it..actually remove the cap and look inside. they are usually stained or discolored...low level is probably the slave cylinder. Cheap and easy fix..hard part is bleeding the air out of the line. if the slave is not leaking, then the clutch master is the culprit...and that one usually does not leak externally. the seal inside will fail and it will not build proper pressure.
 

· Banned
Joined
·
20 Posts
Discussion Starter · #6 ·
Thanks alot guys!! It was low on clutch fluid so i will check if the slave is leaking! I might just replace the slave and master cylinder because im gonna be building the car soon so it will have all new everything. I plan on keeping tha little toy for ever being that its the most enjoyable car i have ever driven in my life.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top