ClubRoadster.net banner

1 - 2 of 2 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hello, I recently purchased this car and it has been a blast so far! It's a 1990 miata with a '00 LS1 from a trans am, it was mechanically great, but aesthetically horrendous. Here's the story:

I installed some indiglo gauges about a week ago, they worked great, I spliced the power off of the center console light by the cupholder. While in the garage doing so the battery tender hanging from the ceiling was touching the windshield wiper frame. When I went to start the car nothing happened, no lights, no clicks, just plain dead, except for the scangauge (aftermarket digital speedo, tach, etc). It flickered a few times, I gave it a power cycle, then I moved the battery tender wire (in case that was shorting it out or something) and fiddled around with the wires under the steering column a little, then it started (although it ran a little rough at first), I drove it for about 25 miles with no issues, so I thought it was fine. Now it happened again. Battery has 12v, no fuses are blown (even the main), theres power going to the cig lighter in ACC, but it turns off when switched to ON, the scangauge flickers again. If I unplug/replug the scangauge it has power in ACC (can get to menus etc) but as soon as I switch to ON it goes out and flickers again. These 2 things seem to be the only things that get any power at all. My worry is that the ecu is fried, but why would it work for 25 miles then stop working again? I'm just so confused as to what might be the problem, maybe a short somewhere? Does this ring a bell to anyone who might know the issue off hand?

Thanks in advance and I will give whatever other info you might need, although the car is 25 miles away at my work, so it might not be quick lol
 

·
Registered
Joined
·
8 Posts
Discussion Starter #2
Figured it out, the nut holding the pos battery cable at the starter solenoid was loose, so there wasn't a good connection and thats where the whole car gets power from. Tightened it up and starts like a champ again. Thanks for all the help guys!
 
1 - 2 of 2 Posts
Top