ClubRoadster.net banner

1 - 17 of 17 Posts

·
Registered
Joined
·
64 Posts
Discussion Starter #1
I'm getting really bad gas mileage. About 140 miles from a full tank of gas (mostly city driving).
Sometimes I can smell fuel really bad inside the car.
The car is completely stock.
What could it be? Bad sensor?
I'm new to miatas.
Thanks
Dan
 

·
Registered
Joined
·
1,340 Posts
Running rich eh?
How many miles on the car?
I First thing i would check is the Cat. It could be clogged. Then check your fuel filter and Injectors. Then the O2 sensor. Hows the performance? Any bog?
 

·
Registered
Joined
·
271 Posts
honestly... when i ran techron and beat the hell out of the car i started to smell fuel for a bit.. but it worked.. you might wanna try that
 

·
Registered
Joined
·
586 Posts
Try one of those Complete Fuel System Cleaner thingies....I had the same problem and after I used it, everything was back to normal.
 

·
Registered
Joined
·
64 Posts
Discussion Starter #6
Car has 135K miles.
Unless properly warmed up the car seem to be bogged down.
The car has new plugs and wires.
Thanks guys. Any other thoughts?
-Dan
 

·
Registered
Joined
·
517 Posts
How do you drive in the city? How long are your trips?

Ive gotten averages as high as 30 mpg and as low as 17mpg on my NB. It all depends how long the trips are and how much throttle I used.
 

·
Registered
Joined
·
489 Posts
I didn't have the fuel odor but I had a bad gas milliage. I found out the my intake cam was off one tooth when I did my timing belt/water pump/seals and junk.

I first noticed when I set the base timing to 14*. My cas was almost maxed out (bolt was almost to very end of the slot). So thought that was weird, so I checked when I had it apart.
 

·
CR.net Supporter
Joined
·
1,390 Posts
leaky injector o ring? leaky tube that goes to the fuel tank? leaky fuel tank? leaky fuel lines? leaky fuel filter?
 

·
Registered
Joined
·
64 Posts
Discussion Starter #10
Most of my trips are short . I don't drive the car very often or very far.
I don't beat it or anything like that.
I have a 94' miata and I don't have these problems or the bad gas mileage.

When I bought the car it had a broken timing belt so I don't know how the car ran before I purchased it. I had the timing belt installed by a professional that I trust.

The gas smell is not always there. The times that it is really strong is under harder than usual excelleration
 

·
Registered
Joined
·
332 Posts
hmm that sounds like me...i think i get really bad gas mileage...like my school is about 7 miles away..but a grip of traffic so it takes like 15 minutes to get there..i go to school 5 days a week..and at the end of the week ...i'm already at half tank...IS THAT RIGHT PEOPLE???
 

·
Registered
Joined
·
517 Posts
Try a long trip and see what happens.

I thought something was wrong with my car until I drove 200 miles round trip to Laguna Seca and got 30mpg average out of the tank.

I think ye with poor gas mileage ought to play around with thou driving style before mechanical fault is suspect.
 

·
CR.net Supporter
Joined
·
3,190 Posts
What about freeway miles? Have you taken a long drive in your car lately? It does seem strange that you're using that much gas, but sitting in traffic for awhile isn't going to be good for your gas mileage....
 

·
Registered
Joined
·
64 Posts
Discussion Starter #16
I'm going to order up a test pipe and see if that does the trick.
Also I have a fuel filter for the 94' that I've not put on yet . Do the 1.8s and 1.6s use the same fuel filter?
I'll let ya know how it goes.
Thanks
Dan
 

·
Registered
Joined
·
15 Posts
I didn't have the fuel odor but I had a bad gas milliage. I found out the my intake cam was off one tooth when I did my timing belt/water pump/seals and junk.

I first noticed when I set the base timing to 14*. My cas was almost maxed out (bolt was almost to very end of the slot). So thought that was weird, so I checked when I had it apart.
How bad was it? Did it run kinda funny after?

I got 19.5 mpg, all city, driving like a total jackass after my timing belt and spark plug change. I'm pretty sure I changed it properly because the intake/exhaust cams refused to line up straight then I noticed my crank sprocket was off a tooth. It took me 3 tries to get it lined up right...but now I'm not sure.
 
1 - 17 of 17 Posts
Top