ClubRoadster.net banner

1 - 20 of 21 Posts

·
Registered
Joined
·
73 Posts
Discussion Starter #4
well about 2 weeks ago...my car broke down...the key in the main pulley broke which kept the alternator from working and completely shut down my car on the freeway...the lights quit working inside and outside the car ...so i bought the $3 key from a mazda dealership and then it ended up costing me $340 for the labor to put the key on the pulley....so i figured that after my car was fixed everthing would be good to go....well guess not the outside lights work just fine, all the interior lights except for the A/C panel and the speedometer lights work...so hopefully its just the bulbs that went out...but if not which fuse do i need to replace??
 

·
Registered
Joined
·
73 Posts
Discussion Starter #8
i checked all the fuses...and all of them are good to go....how do i get behind the guage cluster to change the bulb...i've taken out my center console plenty of times to get to my cd player, but have never taken out the guage cluster...my tail lights work just fine....everything works except the HVAC panel and the guage lights
 

·
Premium Member
Joined
·
9,430 Posts
You gotta pull the whole instrument cluster to get back there.

Not terribly difficult, but still takes a bit of time. Hardest part is making sure not to snap off the clips that hold the meter hood in place.

You'll probably want to remove the plastic shroud around hte steering clock, makes things a lot easier but i think it's necessary to do so aynwho. There are two screws on the underside of the meter hood that hold it in place, take those two out. Next, gently pull up along the back side of the meter hood to make it pop out of hte clips holding it in place. With that out of the way there are a couple screws holding the gauge assembly to the dash support, so take those out, pull the gauges out slightly, unplug the tach cable, then do the same to the two wire harnesses along the top of hte gauge cluster.

et voila.

The bulbs are held in place by little twist-in fittings.
 

·
Registered
Joined
·
30 Posts
Yes, I also need to know which fuse needs to be replaced, as my gauge cluster, and front and rear running lights don't work as well.

I also don't have the fuse box cover to see which fuse is which.

Can someone please tell me which fuse I need to replace?

Thanks
 

·
Registered
Joined
·
73 Posts
Discussion Starter #11
its one of the fuses in the engine compartment....not in the main fuse box...but its one of the grey and black fuses....they cost like $30 to replace
 

·
Registered
Joined
·
30 Posts
Well the thing is, I replaced my 15amp tail fuse, and my speedo lights and parking lights turned on.

But the odd thing is, they stay turned on, even without the headlights being on........
 

·
Registered
Joined
·
372 Posts
you #15 fuse if blown, replace it. its located near the clutch pedal
 

·
Registered
Joined
·
1 Posts
hmmm...i bet your taillights don't work either.
I am having the same problem with no speedometer light. My tail lights are out too! I replaced the fuse. What now? No error codes when a tester was used on my car. Please help if you have any ideas what may be wrong. Yes, I replaced both tail light bulbs.
 
1 - 20 of 21 Posts
Top