ClubRoadster.net banner

1 - 18 of 18 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter #1
hi i have a 1991 miata owned it for about 2 months and had no problems only acouple things i thought i should ask and see if its anything too serious(don't know cars to well) but, first one last night after driving it quite a bit i turned it on and it started revving from 1-3k just up and down and wouldnt stop i turned it off and didnt touch it. This morning i went at it again and it was still doing it. i waited till after i got off work now that its really hot outside and its ok but, still at about 1k constatly. what could this be? oh and the second thing is when i come to a stop i usually throw it in neutral and it'll idle kinda hard the body will shake a bit and rpms will stay at like 1.5k is this normal?
thanks
 

·
Administrator
Joined
·
15,691 Posts
Bad IACV or possibly a vacuum leak.
 

·
Administrator
Joined
·
15,691 Posts
Idle Air Control Valve. :)

As for the vacuum leak... you would find it. Then... make it not leak. :lol:
 

·
Supporting Member
Joined
·
1,724 Posts
Scrap the car, it's junk. Most likely you have holes in your pistons.
 

·
Registered
Joined
·
39 Posts
Discussion Starter #6
really wow thats not what i wanted to hear it's my first car =/ really dont have the money too scrap it or get another one
 

·
Supporting Member
Joined
·
1,724 Posts
I'm just kidding sorry I didn't think you'd believe me.
 

·
Supporting Member
Joined
·
1,724 Posts
I would research cleaning your iac or isc.
 

·
Registered
Joined
·
400 Posts
Scrap the car, it's junk. Most likely you have holes in your pistons.
really wow thats not what i wanted to hear it's my first car =/ really dont have the money too scrap it or get another one
I'm just kidding sorry I didn't think you'd believe me.

HAHAHA. Beautiful. :)

Anyway, yeah, check your vacuum lines. Soapy water on the lines help find leaks. Also, IACV like everyone else has said. Good Luck!
 

·
Supporting Member
Joined
·
1,724 Posts
Well I'm glad we all got a laugh out of it.
 

·
Big Pimpin'
Joined
·
8,505 Posts
My car did something similar when the cam angle sensor went out. It will cause the car to idle funny and really effect acceleration. Does the car sputter when you press on the gas pedal? If it does, then you could have a faulty CAS.

I wouldn't discount the other ideas though. I had my CAS and clutch slave go out at the same time, thus making the car impossible to drive.
 

·
Registered
Joined
·
39 Posts
Discussion Starter #13
no it doesn't sputter but sometimes it feels as though i can press pretty hard on the gas and it wont pick up and quick as it should. its weird it already stopped revving but when i turn it on it without moving it'll sit at about 1k rmps now i drove it around the block acouple times and it drove just fine.
 

·
Registered
Joined
·
39 Posts
Discussion Starter #14
but im still gonna have someone check all those things the vacuum lines and all the other stuff just too be on the safe side.
 

·
Big Pimpin'
Joined
·
8,505 Posts
How many miles does your car have?
 

·
Big Pimpin'
Joined
·
8,505 Posts
Cool. It's a safe bet that unless, that stuff was replaced around the 100k mark, your car may be overdue. My stuff went out around 90-100k, so it's not surprising that you're having issues.
 

·
Registered
Joined
·
39 Posts
Discussion Starter #18
yup the only thing thats been replaced was clutch and timing belt so just gonna have it all replaced so i wont have to worry about it
 
1 - 18 of 18 Posts
Top